import re
regex = re.compile(r"\b(\w{7})\w+", flags=re.MULTILINE)
test_str = "I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing."
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)