using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w{7})\w+";
string substitution = @"\1";
string input = @"I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}