re = /\b(\w{7})\w+/m
str = 'I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result