#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\w{7})\w+"
Local $sString = "I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)