$re = '/\b(\w{7})\w+/m';
$str = 'I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;