const regex = new RegExp('\\b(\\w{7})\\w+', 'gm')
const str = `I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);