import Foundation
let pattern = #"\b(\w{7})\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)