use strict;
my $str = 'I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.';
my $regex = qr/\b(\w{7})\w+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";