# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)\s+\.\s+(\d+)/$1.$2/gm;t' <<< "Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36"