package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s+\.\s+(\d+)`)
var str = `Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}