re = /(\d+)\s+\.\s+(\d+)/m
str = 'Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36'
subst = '$1.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result