use strict;
my $str = 'Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36';
my $regex = qr/(\d+)\s+\.\s+(\d+)/mp;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";