import Foundation
let pattern = #"(\d+)\s+\.\s+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)