// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\s+\.\s+(\d+)").unwrap();
let string = "Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36";
let substitution = "$1.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}