#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)\s+\.\s+(\d+)"
Local $sString = "Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)