const regex = /(\d+)\s+\.\s+(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s+\\.\\s+(\\d+)', 'gm')
const str = `Personal Expenses \$ 14 . 56, Meals \$ 65 . 54, Medical Bills \$ 205 . 36`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);