# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a href=".*?)"(.*?)"(.*)/$1'$2'$3/gm;t' <<< "<p style=\"abc\" rel=\"blah blah\"> Hello I am p </p> <a href=\"https://example.com/abc?name=\"xyz&123\"\"></a>"