import Foundation
let pattern = #"(<a href=".*?)"(.*?)"(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1'$2'$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)