import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a href=\".*?)\"(.*?)\"(.*)";
final String string = "<p style=\"abc\" rel=\"blah blah\"> Hello I am p </p> <a href=\"https://example.com/abc?name=\"xyz&123\"\"></a>";
final String subst = "$1'$2'$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}