$re = '/(<a href=".*?)"(.*?)"(.*)/m';
$str = '<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>';
$subst = "$1'$2'$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;