const regex = /(<a href=".*?)"(.*?)"(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a href=".*?)"(.*?)"(.*)', 'gm')
const str = `<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>`;
const subst = `$1'$2'$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);