// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<a href=".*?)"(.*?)"(.*)"#).unwrap();
let string = "<p style=\"abc\" rel=\"blah blah\"> Hello I am p </p> <a href=\"https://example.com/abc?name=\"xyz&123\"\"></a>";
let substitution = "$1'$2'$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}