re = /(<a href=".*?)"(.*?)"(.*)/m
str = '<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>'
subst = '$1\'$2\'$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result