package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a href=".*?)"(.*?)"(.*)`)
var str = `<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>`
var substitution = "$1'$2'$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}