use strict;
my $str = '<p style="abc" rel="blah blah"> Hello I am p </p> <a href="https://example.com/abc?name="xyz&123""></a>';
my $regex = qr/(<a href=".*?)"(.*?)"(.*)/mp;
my $subst = '$1\'$2\'$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";