using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a href="".*?)""(.*?)""(.*)";
string substitution = @"$1'$2'$3";
string input = @"<p style=""abc"" rel=""blah blah""> Hello I am p </p> <a href=""https://example.com/abc?name=""xyz&123""></a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}