# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(([A-Z])|([a-z]))(\w)?(\w*)(\W+)/${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}/g;t' <<< "Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY "