// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([A-Z])|([a-z]))(\w)?(\w*)(\W+)").unwrap();
let string = "Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY ";
let substitution = "${2:+\\U$4\\L$5\\L$1ay$6:\\L$4\\L$5\\L$1ay$6}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}