import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([A-Z])|([a-z]))(\\w)?(\\w*)(\\W+)";
final String string = "Hello! How are you today?\n"
+ "My name is Nikhil, and I am here to have fun! And do all sorts of things today.\n"
+ "Do you understand me?\n"
+ "YES! I TOTALLY ";
final String subst = "${2:+\\U$4\\L$5\\L$1ay$6:\\L$4\\L$5\\L$1ay$6}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}