import Foundation
let pattern = #"(([A-Z])|([a-z]))(\w)?(\w*)(\W+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)