using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([A-Z])|([a-z]))(\w)?(\w*)(\W+)";
string substitution = @"${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}";
string input = @"Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}