# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([A-Z])|([a-z]))(\w)?(\w*)(\W+)"
test_str = ("Hello! How are you today?\n"
"My name is Nikhil, and I am here to have fun! And do all sorts of things today.\n"
"Do you understand me?\n"
"YES! I TOTALLY ")
subst = "${2:+\\U$4\\L$5\\L$1ay$6:\\L$4\\L$5\\L$1ay$6}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.