const regex = /(([A-Z])|([a-z]))(\w)?(\w*)(\W+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-Z])|([a-z]))(\\w)?(\\w*)(\\W+)', 'g')
const str = `Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY `;
const subst = `${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);