package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([A-Z])|([a-z]))(\w)?(\w*)(\W+)`)
var str = `Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY `
var substitution = "${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}"
fmt.Println(re.ReplaceAllString(str, substitution))
}