$re = '/(([A-Z])|([a-z]))(\w)?(\w*)(\W+)/';
$str = 'Hello! How are you today?
My name is Nikhil, and I am here to have fun! And do all sorts of things today.
Do you understand me?
YES! I TOTALLY ';
$subst = "${2:+\U$4\L$5\L$1ay$6:\L$4\L$5\L$1ay$6}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;