# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/for\ tomorrow[^.]*//gm;t' <<< "The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy."