#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)for\ tomorrow[^.]*"
Local $sString = "The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)