using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"for\ tomorrow[^.]*";
string substitution = @"";
string input = @"The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}