import re
regex = re.compile(r"for\ tomorrow[^.]*", flags=re.MULTILINE)
test_str = "The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)