re = /for\ tomorrow[^.]*/m
str = 'The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result