#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{4})_(\d{2})_(\d{2})_(.*).md"
Local $sString = "2005_03_19_this_is_the_filename.md" & @CRLF & _
"2007_07_23_another_filename.md" & @CRLF & _
"2021_01_12_filename.md"
Local $sSubst = "$1/$2/$4/index.md"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)