import re
regex = re.compile(r"(\d{4})_(\d{2})_(\d{2})_(.*).md", flags=re.MULTILINE)
test_str = ("2005_03_19_this_is_the_filename.md\n"
"2007_07_23_another_filename.md\n"
"2021_01_12_filename.md")
subst = "$1/$2/$4/index.md"
result = regex.sub(subst, test_str)
if result:
print(result)