import Foundation
let pattern = #"(\d{4})_(\d{2})_(\d{2})_(.*).md"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2/$4/index.md"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)