import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})_(\\d{2})_(\\d{2})_(.*).md";
final String string = "2005_03_19_this_is_the_filename.md\n"
+ "2007_07_23_another_filename.md\n"
+ "2021_01_12_filename.md";
final String subst = "$1/$2/$4/index.md";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}