$re = '/(\d{4})_(\d{2})_(\d{2})_(.*).md/m';
$str = '2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md';
$subst = "$1/$2/$4/index.md";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;