using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})_(\d{2})_(\d{2})_(.*).md";
string substitution = @"$1/$2/$4/index.md";
string input = @"2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}