use strict;
my $str = '2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md';
my $regex = qr/(\d{4})_(\d{2})_(\d{2})_(.*).md/mp;
my $subst = '$1/$2/$4/index.md';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";