const regex = /(\d{4})_(\d{2})_(\d{2})_(.*).md/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})_(\\d{2})_(\\d{2})_(.*).md', 'gm')
const str = `2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md`;
const subst = `$1/$2/$4/index.md`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);