#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$"
Local $sString = "Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4" & @CRLF & _
"Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)