import re
regex = re.compile(r"(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$", flags=re.MULTILINE)
test_str = ("Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4\n"
"Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4")
subst = "$1$3"
result = regex.sub(subst, test_str)
if result:
print(result)